Omnify Hotspot 2.2

August 25, 2020

We're delighted to announce the release of Omnify Hotspot 2.2. This release contains several improvements based on your feedback. Please send your comments and suggestions to us, we like to read and use them!

Block advertisements

You can now block those annoying and unwanted advertisements per device. Previously, blocking advertisements was applied to each device.

.NET Core

Starting with this release, you need to have at least .NET Core 3.1 installed. .NET Framework has received its last major version and .NET Core is the future of .NET. If you don't have it installed then our installer can automatically install it for you.

What else?

The network driver has been updated and the issues that you've reported have all been fixed.

Download